[Wellington] Hīkoi mō te Tiriti - Temporary Parking Changes
Incident Report for Mevo
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 17:28 NZDT
Monitoring
From approximately 9:00am until 4:00pm 19th November Hīkoi mō te Tiriti will be taking place in Wellington Central. Please expect delays or potential road closures in Courtenay Place, Manners Street, Willis Street, Waitangi Park, Lambton Quay and surrounding areas. Some parking in Wellington will be reserved for vehicles travelling with the hīkoi. Please adhere to any temporary parking restrictions displayed and check for temporary signage when ending your trip. Check the Map & Parking screen to see forbidden parking zones.

For updates, refer to www.wellington.govt.nz/news-and-events/news-and-information/hikoi.

If you require support or guidance, please do not hesitate to reach out to our team via the in-app chat.
Posted Nov 18, 2024 - 13:47 NZDT